Which must-use plugins are pre-installed?

 

At Pressidium, each WordPress site is provisioned with a small number of pre-installed plugins (they are called must-use plugins) which cannot be disabled or altered in any way. These plugins do protect your site and in general they optimize your WordPress to work properly in the special Pressidium environment.

Currently, we do pre-install the following plugins :

  • Pressidium Plugin - This is our custom plugin which seamlessly integrates your WordPress site with the Pressidium platform. Things like instant backup, cache invalidation, etc are all handled here.
  • Limit Login Attempts - This very useful plugin attempts to block an Internet address from making further attempts after a specified limit on retries is reached, making a brute-force attack difficult or impossible. Please, read the I have been locked out from my site support article, in the case you have locked down your self
  • Enforce Strong Password - This plugin forces users to enter something strong when updating their passwords.

If you need more must-use plugins installed, then you may install them - but you may not disable any of the above pre-installed plugins as they are considered part of the Pressidium platform.