Multi PHP Runtime FAQ

We offer a multi-PHP runtime environment where you can configure your individual sites to run specific PHP runtimes.

Which PHP runtimes are supported ?

We currently support PHP 5.6 and PHP 7.0. Read all about the awesome benefits that PHP 7 introduced here.

Is there a default PHP runtime ?

We use PHP 7.0 as the default PHP runtime. Every newly created WordPress site uses that version by default.

Can I change the PHP runtime of a site ?

Yes, you can change the PHP runtime of your site anytime you want,  from the Pressidium Portal.

Where can I see the current PHP runtime of my site ?

You can verify the current PHP runtime of your site from the Pressidium portal by doing the following:

  1. Click the Websites tab.
  2. Select your website by clicking on its name.
  3. Scroll down to the WordPress Management section.

php-runtime-view

You can see (and change) the current PHP runtime by selecting the version from the PHP Engine dropdown menu.

Can I set different a PHP runtime per site environment ?

Yes, you can use a different PHP runtime in each site environment. For example, you can configure your site's staging environment to run on PHP 7.0, while having your live one (production) on PHP5.6.